
SPSS Output and Graphics for 
Publication  

Academic Computing Services 
A Division of Information Services 

www.ku.edu/acs 
 

Abstract: This document is used in conjunction with the workshop “SPSS: 
Output and Graphics for Publication” and focuses on strategies 
for creating tables and charts suitable for publishing in print and 
electronic publications (journals, books, Web sites, and so on). 
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Introduction 
In this workshop, you will learn how to create publication- and presentation-quality graphics 
and statistical tables in SPSS. We will change the layout and formatting of the standard SPSS 
table output and charts, using the SPSS output and chart editors, and prepare tables and charts 
for export to Word, PowerPoint, the Web, and other publication or presentation tools. 

Prerequisites 
A basic understanding of statistical analysis, and the means of performing that analysis using 
SPSS, is a prerequisite for working with SPSS tables and charts (output). Attending the SPSS: 
Introduction workshop prior to the SPSS: Output and Graphics for Publication workshop 
is highly recommended. 

Related Training Available from ACS 
All workshops offered by Academic Computing Services (ACS), a division of Information 
Services, are free to KU students, staff, faculty, and approved affiliates. The general public is 
also welcome to most workshops, but some ACS workshops require a registration fee for them. 

To learn more about or register for workshops, receive automatic announcements of upcoming 
workshops, and track workshops you’ve registered for and have attended, visit the ACS Web 
site at www.ku.edu/acs/train. You can also check our online schedule at 
www.ku.edu/acs/schedule for a list of class offerings and their availability. For further 
workshop related questions, please email training@ku.edu. 
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Creating and Modifying Pivot Tables 

Modifying Table Contents and Structure 

Delete Data 
To delete data from a cell, row, or column, select the cell, or row/column (you can select the 
row or column by pressing and holding Ctrl+Alt, then clicking the row or column), then press 
Delete key or click the Edit menu and choose Clear. This will leave the category but remove 
the data and headings. 

Hide (and Show) Data 
To completely hide a row or column, select it (by pressing and holding Ctrl+Alt, then clicking 
the row or column), then click the View menu and choose Hide. 

To show any rows or columns that you’ve hidden in a table, double-click inside the table, then 
click the View menu and choose Show All. 

Rename a Heading or Title 
Double-click the text you want to change, and type in the new text. 

Add Footnotes and Captions 
To add a footnote to a pivot table: 

1. Double-click the table to select it. 

2. Click the cell in which you want to insert the footnote. 

3. Click the Insert menu and select Footnote. This will insert a footnote marker in the cell, 
and add a space at the bottom of the table to type in the footnote text, as shown here: 

 
4. Scroll to the bottom of the table, double-click the footnote text area, and type in the 

footnote text. 

To add a caption to a table: 

1. Double-click the table to select it. 

2. Click the Insert menu and select Caption. 

3. Scroll to the bottom of the table, double-click the caption text area, and type in the caption. 

To remove a caption or a footnote, click it (the note or caption itself, not the superscripted 
number) and press the Delete key. 
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Transpose Rows and Columns 
To transpose the layout of a table (change rows into columns and vice versa), 

1. Double-click the table to select it. 

2. Click the Pivot menu, and then click Transpose Rows and Columns.  

 

Restructure a Pivot Table using Pivoting Trays 
If the Pivoting Trays are not already visible, double-click to select the table, click the Pivot 
menu, and click Pivoting Trays. 

 

To change the structure of a table, click and drag one of the icons ( ). These can be moved  

� from a row to a column or vice versa; 

� from a row or column to a layer, which creates a layer in the table (that you can view in the 
table by clicking a drop-down menu); 

� within a row or column to change the order in which categories are displayed. 
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Hint: clicking an icon causes the items it represents to be shaded in the pivot table, like this: 

 

Modifying Table Formatting 

TableLooks 
One of the simplest ways to change the formatting of a pivot table is to apply a different 
TableLook. TableLooks are preset templates that control the appearance of a table (font and 
font size, borders, colors, and so on). 

To apply a TableLook: 

1. Double-click the table to select it. 

2. Click the Format menu and click TableLooks…. 
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3. In the TableLooks dialog box, click the Browse button, and browse to the Looks folder, 

located in the SPSS program folder (usually this will be in the Program Files folder). 

4. Click to select the TableLook (.tlo file) that you want to preview, and click the Open 
button. 
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5. In the TableLooks dialog box, you will see a preview of your table with the TableLook 
applied: 

 
6. To apply this look to the table, click OK; otherwise, click Browse and select another look 

to preview, or click Cancel and format the table manually. 

Formatting Tables Manually 
There are several ways to set properties for tables and table cells: 

• Select the area you want to format (a table, row, column, or cell), and use the tools on the 
formatting toolbar to change the fonts, font sizes, colors, and so on. 

• Select the table, click the Format menu, and then click Table Properties. 

• Select the rows, columns or cells you want to format, click the Format menu, and then 
click Cell Properties. 

Once you make the formatting changes you want to your table, you can save those settings as a 
TableLook and apply it to other tables by selecting the table, clicking the Format menu and 
clicking TableLooks, then clicking the Save As button. Name the look (the .tlo file), and click 
Save. 
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Modifying Charts 
Once you have created the chart you want, you can change the formatting of that chart by 
double-clicking it in the SPSS Viewer, which launches the SPSS Chart Editor, as seen here: 

 
You can use the Chart Editor to modify 

• colors and fill patterns used in the chart; 

• line styles 

• text and placement of the chart labels 

• titles and captions 

• marker types (for scatterplots) 

• 3-D and other visual effects 

Chart Templates 

Saving a Chart Template 
Once you have the chart looking the way you want it to, you can save those formatting settings 
as a Chart Template, using the Chart Editor. To do this, click the File menu in the Chart Editor, 
and choose Save Chart Template. Name the file and save it. 
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Applying a Chart Template 
To apply a chart template that you’ve saved, double-click the chart in the SPSS Viewer to 
launch the Chart Editor. In the Chart Editor, click the Format menu and choose Apply Chart 
Template. Browse to one of the chart templates you’ve created (.sct files) and open it. The 
formatting for that template will be applied to your chart. 

Exporting Tables and Charts to Other Programs 

Exporting vs. Copying and Pasting 
If you want to insert a table or chart created in SPSS in documents or presentation files, there 
are two basic ways to do it. The first is to copy the item from the SPSS output (.spo) file and 
paste it directly into the document or presentation file. The second is to export the table or 
chart, saving it as an independent file, which can then be inserted into the document or 
presentation file. 

 

 Tables Charts 

Print publication 
(word processor or 
desktop publishing 
file) 

Adjust formatting in SPSS as 
needed, then copy/paste into the 
document (recommended). 

- or - 

Export as tab-separated data, 
then import into the document 
and format as needed. 

Adjust formatting in SPSS as 
needed, then export as an EPS, 
TIFF, BMP, or JPEG file. Consult 
the help file of the word 
processing or desktop publishing 
program to determine the best 
image file type (recommended). 

Adjust formatting in SPSS as 
needed, then copy/paste into the 
document. 

Presentation 
(PowerPoint or 
similar) 

Adjust formatting in SPSS as 
needed, then copy/paste into the 
document (recommended). 

- or - 

Export as tab-separated data, 
then import into the document 
and format as needed. 

Adjust formatting in SPSS as 
needed, then export as a BMP, 
or JPEG file. Consult the help 
file of the word processing or 
desktop publishing program to 
determine the best image file 
type (recommended). 

Adjust formatting in SPSS as 
needed, then copy/paste into the 
document. 

Web Page Adjust formatting in SPSS as 
needed, then export as HTML; 
copy and paste the HTML code 
for the table into the Web page. 

Adjust formatting in SPSS as 
needed, then export as a JPEG 
or PNG file. Use a text editor or 
Web authoring tool to insert the 
image in the Web page, then 
publish the page and the image 
file using an FTP program or 
Web authoring tool. 
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For Print Publications 
If you are reporting the results of your research in a journal article, monograph, dissertation, or 
other document that will be printed, you can use several methods to move tables and charts 
from the SPSS Output window to your new document. 

Copy and Paste 
To copy the table or chart from the SPSS Output window and paste it into the new document: 

1. Click the table or chart in the SPSS Output window, click the Edit menu and choose Copy 
or Copy Object. 

Note: If you choose Copy when copying a table from the SPSS Output 
window and then paste it into a document, the results will be editable 
(you can change the text of the table, the formatting, and so on).  

If you choose Copy Object and then paste, the table will be pasted in 
as a graphic object that cannot be edited or modified. 

Charts are always pasted as graphic objects that cannot be edited or 
modified. 

2. Switch to the document window (such as Word or WordPerfect), click the Edit menu and 
choose Paste. 

Export and Import/Insert/Place 
To export a table from the SPSS Output window: 

1. Click the table once to select it. 

2. Click the File menu and choose Export. The Export Output dialog box will appear: 

 
3. In the Export drop-down box, select either “Output Document” or “Output Document (No 

Charts).” 
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4. In the Export File box, type in the path and file name for the exported file, or click the 
Browse button and select the folder in which you want to save the exported file. 

5. Under Export What, choose “All Object” to export the contents of the entire output (.spo) 
file. Choose “All Visible Objects” to export only the contents that appear on the screen. 
Choose “Selected Objects” to export only the table you have selected. 

6. Under Export Format, choose the type of file you want to create. “HTML” will create a 
Web page; the HTML code can also be inserted into another HTML file. “Text file” is used 
to create either a tab- or space-delimited text file (click the Options button to choose 
which). Choosing “XML” results in XML-formatted data that can be viewed like HTML or 
parsed by an XML editor. 

For the Web 
Saving output (table, charts or both) for the Web requires some working knowledge of HTML 
– or help from someone who has that knowledge. Unlike print documents, there is no way to 
copy and paste output directly into a Web document; instead, you must export the charts as 
Web-friendly images, and the tables as HTML code. 

Charts for the Web 
When exporting charts for the Web, you will need to select an image file type that is 
compatible with Web browsers. In SPSS, your two choices are JPEG and PNG; the other 
image file types will not work on the Web. Additionally, the PNG file format may not work 
with older browsers. (Internet Explorer version 4 for PC and 5 for Mac and above, and 
Netscape 4.04 and above can display PNG files.) 

To export a single chart: 

1. Click the chart once in the SPSS Viewer to select it. 

2. Click the File menu and choose Export. The Export Output dialog box will appear: 

 
3. In the Export drop-down box, choose Charts Only. 
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4. In the Export File text box, browse to the folder in which you want to save the chart, and 
type in the file prefix you want to use (the default is “OUTPUT”). 

5. Under Export What, choose Selected Charts. 

6. Under Export Format, choose either JPEG File or PNG File. 

7. To change the files size and color settings for the image, click the Options button. To 
reduce the file size of the image, you can change the Color Depth to 256 grays, choose a 
decreased Color Space, and/or adjust the Compression Quality Setting (a higher 
compression/lower image quality results in a smaller file size for the image). Click 
Continue to apply the changes. 

 

 
8. In the Export Output dialog box, click the Chart Size button to make the exported image 

bigger or smaller than the original. Click Custom and type in the percentage value (can be 
less than or greater than 100% of the original chart size). Click Continue to apply the 
change. 

 
9. In the Export Output dialog box, click OK to export the image. 
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Tables for the Web 
When you export tables for the Web, the result is a plain text file containing HTML code. This 
code can be copied and pasted into another Web page, or published as an independent Web 
page. 

To export a table for the Web: 

1. Click the table you want to export, then click the File menu and choose Export. 

2. In the Export drop-down box, choose Output Document or Output Document (No 
Charts). 

3. In the Export File text box, browse to the folder in which you want to save the table, and 
type in the file prefix you want to use (the default is “OUTPUT”). 

4. Under Export What, choose Selected Objects. 

5. Under Export Format, choose HTML. 

6. Click OK to export the table. 

Once you’ve exported the table as HTML, you can view the file in a Web browser, edit or copy 
the HTML code in a Web authoring tool (such as Dreamweaver) or a text editor (such as 
Notepad), and paste the code into another Web page file. 

For More Information 
Here are some additional sources of information about graphics and tables in SPSS: 

Print 
• SPSS Base 11 User’s Guide and SPSS 11 Interactive Graphics User’s Guide (bundled) 

• SPSS 11 for Windows Brief Guide (contains basic tutorials) 

• Field, Andy. Discovering Statistics Using SPSS for Windows: Advanced Techniques for 
the Beginners. London: Ism, 2000. 

Online 
• SPSS Tutorial (included with SPSS); to launch the tutorial, start SPSS, click the Help 

menu, then click Tutorial. 

• SPSS Technical Support (http://www.spss.com/tech/). Contains links to AnswerNet 
(below); SPSS patches, macros, and utilities; and email lists/newsgroups dedicated to SPSS 
and statistical analysis. 

• SPSS AnswerNet (http://www.spss.com/tech/answer/). Allows the user to search the SPSS 
technical support database for answers to common questions and solutions to common 
problems. 
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Getting Additional Help 
Academic Computing Services provides consulting and Q&A help in a variety of ways: 

785/864-0200 
question@ku.edu 
www.ku.edu/acs/help 

 

To evaluate this course online, please visit www.ku.edu/acs/training/evaluation 

 
Last Update: 07/22/2002 

mailto:question@ku.edu
http://www.ku.edu/acs/help
http://www.ku.edu/acs/training/evaluation

	Introduction
	Prerequisites
	Related Training Available from ACS
	Creating and Modifying Pivot Tables
	Modifying Table Contents and Structure
	Delete Data
	Hide (and Show) Data
	Rename a Heading or Title
	Add Footnotes and Captions
	Transpose Rows and Columns
	Restructure a Pivot Table using Pivoting Trays

	Modifying Table Formatting
	TableLooks
	Formatting Tables Manually


	Modifying Charts
	Chart Templates
	Saving a Chart Template
	Applying a Chart Template


	Exporting Tables and Charts to Other Programs
	Exporting vs. Copying and Pasting
	For Print Publications
	Copy and Paste
	Export and Import/Insert/Place

	For the Web
	Charts for the Web
	Tables for the Web


	For More Information
	Print
	Online

	Getting Additional Help

